No components marked as affected
Resolved
We think the impact from the issue is over.
Investigating
We are currently experiencing issues with the delivery of institution status alerts. Some customers may not receive timely notifications about institution health changes.We are actively investigating the issue.